LaVOZs

The World’s Largest Online Community for Developers

'; gsm - error +HTTPACTION:0,601,0 - LavOzs.Com

I m trying to access a website using sim900 GSM module. This is the list of commands

AT+CSQ      
+CSQ: 16,0          

OK  
AT+HTTPINIT           
OK  
AT+HTTPPARA="CID",1                   
OK  
AT+HTTPPARA="URL","www.google.com"                                  
OK  
AT+HTTPACTION=0               
OK  

+HTTPACTION:0,601,0                         

AT+HTTPACTION=0
OK

+HTTPACTION:0,601,0

Unable to access google. 601 code shows Network error. How to get rid of this error?

You need to setup the connection to the bearer. Here are the minimum setup commands that have worked for me (based on trial/error and searching around on the internet).

AT+SAPBR=3,1,"APN","wap.cingular"
AT+SAPBR=1,1

The correct value for the APN may be different for you, depending on your network and service provider. I'm using AT&T prepaid SIM cards. Once that's working, then you can do the HTTP setup commands as you already have...

AT+HTTPINIT
AT+HTTPPARA="URL","http://www.google.com"
AT+HTTPACTION=0

Status codes above 600 (and some in the 500 range) are unassigned in the HTTP standard. In the AT command manual for the SIM908, status meanings are given in the notes on the HTTPACTION command:

600 Not HTTP PDU
601 Network Error
602 No memory
603 DNS Error
604 Stack Busy

You can query the bearer connection status of CID 1 with AT+SAPBR=2,1 and the related parameters with AT+SAPBR=4,1. You can also check that you're attached to the GPRS network with AT+CGATT?. If everything indicates that you are connected and you are still getting a 601 status code, then check that your service plan has data and that it hasn't run out. I have found that even when my account has a few hundred k of data showing on the balance that I start to get a 601 status until I add more data to my prepaid phone plan. If the SIM module has been on the whole time and you add more data, you'll need to close and re-open your connection (AT+SAPBR=0,1 followed by AT+SAPBR=1,1) and then your HTTP* commands will start working again without having to set the HTTPPARA settings again and without having to restart with HTTPINIT.

I have found that when an http call is made to an https only website it will throw a 601 error on the sim. Beware some sim devices have ssl and some don't. Use AT+HTTPSSL=? to interrogate. device with ssl will respond like, 'HTTPSSL 1'. If you get an error your device doesn't have ssl. This took some work with the factory for me to determine this.

You must also use to hit ssl site. I am using the wifi101 ssl client.

fona.setHTTPSRedirect(true); dy3

I have encoutered this error as well. The cause of the problem may be that there is not enough money in the phone number account. You may check it.

I have spent many hours with this module right now.

My experience is that when you dont get a 200 reply from remote server, you should check IP address to verify you are still on the network sendng a ping to a working server (AT+CIPPING="XX.XX.XX.XX").

If it succeeds: Try AT+SAPBR=2,1 and AT+CIFSR. You should get same address for both commands.

If you dont get same address, login again to the netword/service with AT+CIPCSGP=1, "yourapn.com", "user", "password".

If nothing works, power down the module. Wait a couple of minutes, and restart again.

Just in case someone is affected by this problem and stumbles on this post 4 years later: in my case the module had a small "sticker" type antenna and it got somehow damaged.

I could connect to the network but when I tried to use HTTP over the GPRS networks I only got return code 601 (network error) or 603 (failed to resolve DNS).

Once I replaced the antenna with a new one, everything worked perfectly.

Again, in case somebody has the same problem. In my case it was a typo in url: AT+HTTPPARA="URL"," http://www.google.com" Did you notice the space before http? For several hours, I didn't notice it too.

601 is some custom implemented Error code.

Here is the list of standard HTTP Status codes

+HTTPACTION:0,601,0

The above AT response code (601) for HTTP session start indicates that there is a network error. Then make sure that the PDP context is setup properly.

source

https://m2msupport.net/m2msupport/at-command-for-http-functions-for-remote-server-data-access/

Change URL. 601 is a URL has been moved. Is a redirect.

Related
Sending AT commands to SIM900 whilst pppd is active
GSM Module CME Error code 15
sim800L gprs post request
arduino and gsm module sim900 how to get messages phone number?
Error in receiving httpget respponse
Store value in variable after HTTPREAD
Python code for network location using SIM800c GSM module